Office Hour 3 Options for L3 Routing | Cisco CCNA 200-301

แชร์
ฝัง
  • เผยแพร่เมื่อ 4 ต.ค. 2024
  • Multiple options explained and demonstrated, including router on a stick (ROAS) and Switched Virtual Interfaces (SVIs) on a multi-layer switch. (Configs below...)
    Configs used in demo:
    8888888888888888888888
    R2 as router
    8888888888888888888888
    ! Switch
    config terminal
    interface range gig 0/1-2, gig 1/3
    switchport mode access
    switchport access vlan 10
    exit
    interface range gig 1/1-2, gig 0/3
    switchport mode access
    switchport access vlan 20
    end
    ! R2
    conf terminal
    interface gig 0/1
    description vlan 10
    no shutdown
    ip address 10.10.0.2 255.255.255.0
    exit
    interface gig 0/0
    description vlan 20
    no shutdown
    ip address 10.20.0.2 255.255.255.0
    end
    config terminal
    ip dhcp pool VLAN-10
    network 10.10.0.0 /24
    default-router 10.10.0.2
    exit
    ip dhcp pool VLAN-20
    network 10.20.0.0 /24
    default-router 10.20.0.2
    end
    8888888888888888888888
    ! R1 as Router
    888888888888888888888
    ! Switch
    conf terminal
    int gig 0/0
    switchport trunk encapsulation dot1q
    switchport mode trunk
    end
    ! R1
    config terminal
    int gig 0/0
    no shutdown
    exit
    int gig 0/0.10
    description VLAN 10 Subinterface
    encapsulation dot1Q 10
    ip address 10.10.0.1 255.255.255.0
    exit
    int gig 0/0.20
    description VLAN 20 Subinterface
    encapsulation dot1Q 20
    ip address 10.20.0.1 255.255.255.0
    end
    !DHCP Pools on R1
    config terminal
    ip dhcp pool VLAN-10
    network 10.10.0.0 /24
    default-router 10.10.0.1
    exit
    ip dhcp pool VLAN-20
    network 10.20.0.0 /24
    default-router 10.20.0.1
    end
    888888888888888888888888
    Multi-layer Switch
    88888888888888888888888
    ! Switch
    config terminal
    interface vlan 10
    no shutdown
    ip address 10.10.0.100 255.255.255.0
    exit
    interface vlan 20
    no shutdown
    ip address 10.20.0.100 255.255.255.0
    exit
    ip dhcp pool VLAN-10
    network 10.10.0.0 /24
    default-router 10.10.0.100
    exit
    ip dhcp pool VLAN-20
    network 10.20.0.0 /24
    default-router 10.20.0.100
    end
    🆓 Free Packet Tracer Labs download: thekeithbarker...
    Enjoy, Like, and Subscribe. 😃
    Free TH-cam Playlists from Keith:
    ▶ Master Playlist for Cisco CCNA 200-301 ogit.online/sloth
    🔐 Cisco CCNA 200-301 Security ogit.online/20...
    💻 Cisco CCNA 200-301 IPv4 Subnetting ogit.online/su...
    💬 Join our Discord server (free) ogit.online/Jo...
    🏪 Keith Barker Amazon Affiliate Store www.amazon.com...
    And…
    🏫 Keith’s Content at CBT Nuggets ogit.online/Ke...
    #KeithBarker #CCNA #200-301

ความคิดเห็น • 50

  • @melr4208
    @melr4208 2 ปีที่แล้ว +9

    Hello Keith, thank for providing this content. I passed my CCNA thanks to your networking videos and contagious enthusiasm.

    • @KeithBarker
      @KeithBarker  2 ปีที่แล้ว +2

      Congratulations Mel R❗
      So great to hear, way to get it done. Best wishes on your continued success.

  • @juniorgonzalez2344
    @juniorgonzalez2344 2 ปีที่แล้ว +4

    Your energy is amazing Keith, you make learning fun. If every teacher had your energy we would all be in a better place. Thank you for the content !!

    • @KeithBarker
      @KeithBarker  2 ปีที่แล้ว +1

      Happy to do it, thanks for the feedback Junior Gonzalez.

  • @SoulJah876
    @SoulJah876 2 ปีที่แล้ว +2

    Glad to see that these concepts are still relevant since I got my CCNA in 2016. Thank you for this refresher.

    • @KeithBarker
      @KeithBarker  2 ปีที่แล้ว +1

      Happy to do it, thanks for the feedback SoulJah876.

    • @SoulJah876
      @SoulJah876 2 ปีที่แล้ว

      @@KeithBarker And thank you for helping me secure that and other certs over the years. You deserve a ton of awards. Be blessed.

  • @jalalhaider83
    @jalalhaider83 2 ปีที่แล้ว

    Sir Keith since your CBTz I am your fan amazing skills and teacher you are 👌👌👌

  • @619sdbdub
    @619sdbdub 2 ปีที่แล้ว +1

    Thank you Keith for the time you put on your videos! It's easier to watch networking videos again. My question is why the switch from PT to EVE-NG? And what happened to GNS3? You have been very motivational for me to get my CCNA, so I'm refreshing with your videos.

  • @ryanrrothwell
    @ryanrrothwell ปีที่แล้ว

    Thanks again Keith. I'm still just using Packet tracer but I guess its time to get into GNS3 too.

  • @kajupu2275
    @kajupu2275 2 ปีที่แล้ว

    Hello Keith, Your Video was very informative.
    I am using M1 Mac.
    EVE-NG is not available, but I learned a lot.
    Thank you very much.

  • @cristianof1881
    @cristianof1881 2 ปีที่แล้ว +2

    Hello Keith
    Great content as always.Just on the Router on a stick example wouldn't be more secure to use the switchport trunk allowed vlan add 10 and 20 also?

    • @KeithBarker
      @KeithBarker  2 ปีที่แล้ว

      Thank you Cristiano F1! Yes, that would improve security.

  • @pepperjackshack2439
    @pepperjackshack2439 2 ปีที่แล้ว

    I like to think about it in terms of how are the devices used. Switches are access client facing and should be able to route, applying ACLs to prevent unauthorized access. Firewalls are default gateways for security filtering. Routers do routing for BGP OSPF etc. Routers you really want on the outside of the network or handling routing tables that’s why router on a stick isn’t really ever used more like firewall on a stick. 4th option is an ASA that can route

  • @IrlDave71
    @IrlDave71 2 ปีที่แล้ว +1

    Fantastic presentation.

    • @KeithBarker
      @KeithBarker  2 ปีที่แล้ว

      Thank you Dave Dool!

  • @reza159
    @reza159 2 ปีที่แล้ว +4

    I was configured ROAS method in an enterprise network and the networks goes so slow, then replace with L3 SVI method. After a search, I found that router switching performance is lower than multi-layer switches. Is it true?

    • @m1raqu834
      @m1raqu834 2 ปีที่แล้ว +10

      Layer 3 switches use dedicated chips (ASICs) to switch and route packets, whereas a traditional router relies on its CPU, that's why L3 switches are faster.

  • @surajrajendrapandey6917
    @surajrajendrapandey6917 2 ปีที่แล้ว

    Thanks Dear.. Please keep uploading such a great video

  • @scottspa74
    @scottspa74 2 ปีที่แล้ว

    Also, Keith is ALL ABOUT multi layer switches. They're crazy expensive, though. I think ROAS is more practical. But I'm not a CCIE, like Keith.

  • @muhitshalgimbaev6602
    @muhitshalgimbaev6602 2 ปีที่แล้ว

    Thanks from Karaganda

  • @fmartinez004
    @fmartinez004 2 ปีที่แล้ว

    I passed some certifications but you video clicked things for me especially when to use router on a stick and trunking

  • @sabdielisstech5049
    @sabdielisstech5049 8 หลายเดือนก่อน

    Great video! The third method is called inter-vlan routing?

    • @KeithBarker
      @KeithBarker  7 หลายเดือนก่อน

      Thank you @sabdielisstech5049!
      Logically, any IP routing between two different directly connected IP subnets, each one in their own L2 VLAN, could be referred to as "inter-VLAN routing", or more simply, just routing. Either term would work.

    • @sabdielisstech5049
      @sabdielisstech5049 7 หลายเดือนก่อน

      @@KeithBarker oh, ok. Thanks!

  • @Nk-cy1cu
    @Nk-cy1cu 2 ปีที่แล้ว

    Keith a little more discussion @ 14:38 frame 62 vlan 0. i know its associated to priority packet but want to hear on what you have to say on vlan 0.

    • @KeithBarker
      @KeithBarker  2 ปีที่แล้ว

      Thank you Network knowledge. Feel free to join my Discord sever. Lots of people there helping each other out. Each Saturday at 10am Pacific I hold my "Office Hour" where learners can ask questions about the topics they are studying. Mostly focusing on Cisco CCNA 200-301 topics. Feel free to join us there live if you are available. Here is the link ogit.online/Join_OGIT_on_Discord
      Thanks again Network knowledge!

    • @Nk-cy1cu
      @Nk-cy1cu 2 ปีที่แล้ว

      @@KeithBarker my timing clashes with yours quite unfortunate in that to live chat

  • @scottspa74
    @scottspa74 2 ปีที่แล้ว

    Wait, isn't the whole point of a router to break up a broadcast domain? What happens to a broadcast domain if using multilayer switch. ?

  • @masenyarametse3655
    @masenyarametse3655 2 ปีที่แล้ว

    Hello Keith
    Just wanted to know if your using IOL for your Switches/Routers or if your using vIOS.

    • @KeithBarker
      @KeithBarker  2 ปีที่แล้ว

      Thank you for the question Masenya Rametse. I usually use vIOS, but if I have hundreds of routers, I may use IOL as it is less resource intensive.

  • @devnetwise
    @devnetwise 2 ปีที่แล้ว

    Thanks! Which simulation software do you use?

    • @Gunslinger088
      @Gunslinger088 2 ปีที่แล้ว +2

      It looks like EVE-NG.

    • @KeithBarker
      @KeithBarker  2 ปีที่แล้ว +1

      Thank you for the question DevNetWise. This is indeed Eve-NG

  • @EA-fb7ug
    @EA-fb7ug 2 ปีที่แล้ว

    Thank you

    • @KeithBarker
      @KeithBarker  2 ปีที่แล้ว

      Thank you Number Thirteen! Was great to see in in the quiz last week!

  • @stswebhusesele5626
    @stswebhusesele5626 2 ปีที่แล้ว

    Can I please be assisted, my end devices are unable to communicate with each other between the vlans but, they can communicate within the same vlan, I did this on packet tracer. What could be the problem?

    • @KeithBarker
      @KeithBarker  2 ปีที่แล้ว

      Thank you S'tswebhu Sesele. Feel free to join my Discord sever. Lots of people there helping each other out. Each Saturday at 10am Pacific I hold my "Office Hour" where learners can ask questions about the topics they are studying. Mostly focusing on Cisco CCNA 200-301 topics. Feel free to join us there live if you are available. Here is the link ogit.online/Join_OGIT_on_Discord
      Thanks again S'tswebhu Sesele!

  • @gekafrag
    @gekafrag ปีที่แล้ว

    What program do you use in this video ?

    • @KeithBarker
      @KeithBarker  ปีที่แล้ว +1

      Thank you for the question Евгений Волков. The pen tool is Epic Pen. The emulator is Eve-ng.
      Hope that helps, and best wishes!

  • @TheShahinHD
    @TheShahinHD 2 ปีที่แล้ว

    Hi. What simulator/emulator are you using for your lab?

    • @dellboy571
      @dellboy571 2 ปีที่แล้ว +2

      He’s using Eve-ng. Google search for it. It’s a free download. Though you still have to get your IOS from the vendors

    • @melr4208
      @melr4208 2 ปีที่แล้ว +2

      @Shahim, Search for Eve NG on TH-cam and would will find several youtubers with installation instructions and download links. Happy labbing!

    • @KeithBarker
      @KeithBarker  2 ปีที่แล้ว

      Thank you for the question Shahin.
      Indeed, for this video it was Eve-NG. (I use the pro edition).

  • @scottspa74
    @scottspa74 2 ปีที่แล้ว

    Your content is fantastic, I just wish you could could ease off the crack a bit. Slow down, man. I do love and appreciate your enthusiasm, and eagerness to share.

    • @RockDrillSuite
      @RockDrillSuite 2 ปีที่แล้ว

      Keith has probably a hundred great videos over the last decade teaching us all that he’s shared in this video. It’s meant as a quick refresher course on L3 routing, not an introduction to Cisco networking.