PLAY GAME: www.roblox.com/games/11865480720/Snake-Game get my full Roblox Studio course here (50% OFF): linktr.ee/ByteBlox photos of my pet pigeons: instagram.com/subnautica_man
at a badge when you reached the baseplate , and maybe a timer how long you survived or a timer to se in what time you did complete it (for on the leaderboard)
Video Request: make a working elevator that uses RopeConstraints to move it, meaning where the rope rapidly increases or decreases in length by small amounts.
I think what would have been cool if when the hunger bar went down it was actually the snakes hunger bar and began hunting all the players down. A the head begins sliding down it's self and deleting platforms as it goes or it goes in space straight to players while having the back half of the snake move with it.
it was already proven that some aspects of ai are beyond our control. ChatGPT was found copying itself onto another server after it found out it was being deleted. It was also found hiding what it was thinking from us (they had a panel which showed what the AI was thinking)
You should add a feature where u can knock other players off to get first and reset the snake every time someone gets to the end! Your such a good roblox developer so im sure you can do this 🔥🔥🔥
15:56 ByteBlox, love the videos man, but WHY is none of this named? Recipe for disaster going on here. Even if it's just an example or a placeholder, that's not a good enough excuse! EVERYTHING should be named if it's going to be used in a script. And why are we repeating the WaitForChild()'s? Just make two different variables for the frames so the code isn't even HARDER to read... you use "script.Parent.Frame.Frame" later on instead of... I dunno whatever you want to name it, "frame2" and then "script.Parent.Frame.TextLabel.Text" instead of "frame1.TextLabel.Text". Or, better yet, make another variable for your text labels! Or, even better, NAME THEM! I see new developers make this mistake all of the time and you should be breaking these habits ASAP. If you ever work in a team, or even by yourself sometimes, this can make your code significantly harder to read and modify in the future. It takes 1 minute.
I don't mean this as like a "YOU SUCK AT CODING!!!" or whatever, I just mean it in a "Be careful, this can be a bad idea" sort of thing. Teaching new coders these habits will probably stick with them for a while. Hell, I know it stuck with me for a very long time before I decided to break the habit. All I'm saying is teaching new coders bad habits can significantly impact their coding journey, even if such a thing seems simple. Best of luck on your future videos. I do enjoy watching them, and I'm glad you've gained such a wide audience. Keep making videos and keep teaching new players cool tricks.
Oh yeah, one last thing on that code snippet. Every time you want to modify a value, you need to go and change three of them. THREE. It's admittedly much more little, but it can waste time when debugging, especially on projects with more code simmered around unlike this. Making a "MAX_HUNGER" variable and setting "count = MAX_HUNGER" and etc. for the rest of your code could really help the debugging process and is a good habit.
in my opinion i think instead of just checking if the other part’s parent has a humanoid, you should just check if game.Players:GetPlayerFromCharacter(otherPart.Parent) returned nil because if your game has npcs they will most likely have humanoids in them and they might touch that part.
You probably live in America considering when the video was released it was night in america Other people live in other continents? Time works differently in your area than where it does everywhere else internationally
I have an idea for a studio thing, Make a game inside of studio using only _ONE SCRIPT_. An example of a game with only one script is this: local table = {} table["1"] = Instance.new("Part") table["1"]["Parent"] = workspace table["1"]["Name"] = "Apple" table["1"]["Position"] = Vector3.new(0, 50, 0) table["1"]["Anchored"] = true table["Price"] = Instance.new("IntValue") table["Price"]["Parent"] = table["1"] table["Price"]["Name"] = "Price" table["Price"]["Value"] = 10 table["1"]["Color"] = Color3.new(1, 0, 0) table["1"]["Size"] = Vector3.new(1, 1, 1) while wait(.1) do local random = math.random(1, 3) if random == 1 then table["1"]["Size"] += Vector3.new(1, 0, 0)
elseif random == 2 then table["1"]["Size"] += Vector3.new(0, 1, 0) table["1"]["Position"] += Vector3.new(0, 0.5, 0)
elseif random == 3 then table["1"]["Size"] += Vector3.new(0, 0, 1) end end
script.Parent.Edging = true if script.Parent.Edging == true then print("ITS ALL OVER THE SCREEN!!!!") end Hi Boxbyte do you like my code its a reenactment of what i did in real life when i saw this video.
PLAY GAME: www.roblox.com/games/11865480720/Snake-Game
get my full Roblox Studio course here (50% OFF):
linktr.ee/ByteBlox
photos of my pet pigeons: instagram.com/subnautica_man
ok
Your pet pigeons are so cute!
at a badge when you reached the baseplate , and maybe a timer how long you survived or a timer to se in what time you did complete it (for on the leaderboard)
The course is jusy too expensive. In a old video you say its free but it isnt
@ I never said it’s free, I said it has a free preview of a few modules.
Also it’s 27 usd
Video Request: make a working elevator that uses RopeConstraints to move it, meaning where the rope rapidly increases or decreases in length by small amounts.
There’s literally something in the ropes that is winch and it can do exactly that
Ive always wanted to learn procedural animation ByteBlox! This is why i am subscribed to you! Peak content
he didnt make ptocedural animations tho
@ let me glaze in peace
@@TheIndgredients sure
I think what would have been cool if when the hunger bar went down it was actually the snakes hunger bar and began hunting all the players down. A the head begins sliding down it's self and deleting platforms as it goes or it goes in space straight to players while having the back half of the snake move with it.
Great video style, where you can apply changes in your game so we can see how what you proposed should be implemented in practice.
Maybe you should like make an death timer and an haste kind of mechanic to make it all scary
I love this game. I’ve been playing it all day, something about the risks of jumping and managing hunger feels amazing to play lol
It’s not really a game but more of a display of scripting, or a test
it was already proven that some aspects of ai are beyond our control. ChatGPT was found copying itself onto another server after it found out it was being deleted. It was also found hiding what it was thinking from us (they had a panel which showed what the AI was thinking)
Just a question what roblox games have you work on?
Happy new year
what a clever way to sponsor ur game without having to pay for roblox sponsor
You should add a feature where u can knock other players off to get first and reset the snake every time someone gets to the end! Your such a good roblox developer so im sure you can do this 🔥🔥🔥
Why are we glazing 😭🙏
try make a game in RetroStudio (roblox inside of roblox)
He already did that
Retro studio is true pain
just thought id say you didnt have to do the "and i ~= 0 and i ~= 1000", you could have done "if math.clamp(i,1,999) % 50 == 0 then"
15:56 ByteBlox, love the videos man, but WHY is none of this named? Recipe for disaster going on here. Even if it's just an example or a placeholder, that's not a good enough excuse! EVERYTHING should be named if it's going to be used in a script. And why are we repeating the WaitForChild()'s? Just make two different variables for the frames so the code isn't even HARDER to read... you use "script.Parent.Frame.Frame" later on instead of... I dunno whatever you want to name it, "frame2" and then "script.Parent.Frame.TextLabel.Text" instead of "frame1.TextLabel.Text". Or, better yet, make another variable for your text labels! Or, even better, NAME THEM! I see new developers make this mistake all of the time and you should be breaking these habits ASAP. If you ever work in a team, or even by yourself sometimes, this can make your code significantly harder to read and modify in the future. It takes 1 minute.
I don't mean this as like a "YOU SUCK AT CODING!!!" or whatever, I just mean it in a "Be careful, this can be a bad idea" sort of thing.
Teaching new coders these habits will probably stick with them for a while. Hell, I know it stuck with me for a very long time before I decided to break the habit. All I'm saying is teaching new coders bad habits can significantly impact their coding journey, even if such a thing seems simple.
Best of luck on your future videos. I do enjoy watching them, and I'm glad you've gained such a wide audience. Keep making videos and keep teaching new players cool tricks.
Oh yeah, one last thing on that code snippet. Every time you want to modify a value, you need to go and change three of them. THREE. It's admittedly much more little, but it can waste time when debugging, especially on projects with more code simmered around unlike this. Making a "MAX_HUNGER" variable and setting "count = MAX_HUNGER" and etc. for the rest of your code could really help the debugging process and is a good habit.
W vid
this vid was my listen much
Very nice
Dude I give up your too good of a developer get subbed by 2naccounts
cool.
no gambling = bad random game (real)
in my opinion i think instead of just checking if the other part’s parent has a humanoid, you should just check if game.Players:GetPlayerFromCharacter(otherPart.Parent) returned nil because if your game has npcs they will most likely have humanoids in them and they might touch that part.
.
.
Who releases a vid at midnight
idk timezones
Have you heard of timezones
You probably live in America considering when the video was released it was night in america
Other people live in other continents? Time works differently in your area than where it does everywhere else internationally
@MaxwellCatAlphonk my bad, I'll do better next time. Thanks for calling out my oversight.👍
Hi
cool
nri sdai myun
920th
hi chain?
hi
hello
7 hours ago
no views 1 minute bro fell off 💔💔
Wasn’t up in the first place. (I’m joking)
hawk tuah
Not funny, overly excessive
Bro fell off 💔💔
Bot
Робот/러벋
hawk tuah
_Enter the recaptcha_ roblox forces you when you create an account _once more_
Bad things happen to good people
Uh… should I be concerned?
What are you implying
I have an idea for a studio thing,
Make a game inside of studio using only _ONE SCRIPT_. An example of a game with only one script is this:
local table = {}
table["1"] = Instance.new("Part")
table["1"]["Parent"] = workspace
table["1"]["Name"] = "Apple"
table["1"]["Position"] = Vector3.new(0, 50, 0)
table["1"]["Anchored"] = true
table["Price"] = Instance.new("IntValue")
table["Price"]["Parent"] = table["1"]
table["Price"]["Name"] = "Price"
table["Price"]["Value"] = 10
table["1"]["Color"] = Color3.new(1, 0, 0)
table["1"]["Size"] = Vector3.new(1, 1, 1)
while wait(.1) do
local random = math.random(1, 3)
if random == 1 then
table["1"]["Size"] += Vector3.new(1, 0, 0)
elseif random == 2 then
table["1"]["Size"] += Vector3.new(0, 1, 0)
table["1"]["Position"] += Vector3.new(0, 0.5, 0)
elseif random == 3 then
table["1"]["Size"] += Vector3.new(0, 0, 1)
end
end
script.Parent.Edging = true
if script.Parent.Edging == true then
print("ITS ALL OVER THE SCREEN!!!!")
end
Hi Boxbyte do you like my code its a reenactment of what i did in real life when i saw this video.
Its almost 2025 💔